SquaredUp cannot start due to an error
SquaredUp cannot start due to an error.
Startup failed for 'Extension packs'.
In the log:
[FTL] Error during startup sequence
System.InvalidOperationException: Exception during startup sequence ---> System.InvalidOperationException: Startup failed for 'Extension packs' ---> System.Data.SQLiteException
FOREIGN KEY constraint failed
Cause
There is a problem with one of the package zip files in the ..\SquaredUpv5\User\ReferencePackages
folder.
Solution
Stop the Dashboard Server application pool.
Add the following lines to the
..\SquaredUpv5\User\Configuration\extensionpacks.json
file:Copy{
"log-level: "debug",
"trace-all-queries": true
}Rename the current log to
.old
(see Where to find log files).Start the Dashboard Server application pool to reproduce the issue.
Review the log for the line
Startup failed for 'Extension Packs'
and check the lines above that error for the last pack that is referenced. This will be the package file that is causing the startup failure.In the following example it was a pack called
opslogixvmware
:Copy2020-12-23 11:53:20.140 >> 011 >> [DBG] DELETE FROM Pack WHERE (ID = '52bc9c4d-1910-460b-86c5-7531a2dff2eb' OR InternalName = 'opslogixvmware');
2020-12-23 11:53:20.140 >> 011 >> [DBG] DELETE FROM Pack WHERE (ID = '52bc9c4d-1910-460b-86c5-7531a2dff2eb' OR InternalName = 'opslogixvmware');
2020-12-23 11:53:20.140 >> 011 >> [DBG] ROLLBACK TO sqlite_dotnet_savepoint_1;
2020-12-23 11:53:20.140 >> 011 >> [DBG] ROLLBACK;
2020-12-23 11:53:20.142 >> 011 >> [FTL] Error during startup sequence
System.InvalidOperationException: Exception during startup sequence ---> System.InvalidOperationException: Startup failed for 'Extension packs' ---> System.Data.SQLite.SQLiteException: constraint failed
FOREIGN KEY constraint failedStop the Dashboard Server Application Pool.
In the
..\SquaredUpv5\User\ReferencePackages
folder, remove the problematic package zip file.Where to find the SquaredUp folder
Name of the SquaredUp folder
The name of the SquaredUp folder is
SquaredUpv
followed by theproduct version number
.Location of the SquaredUp folder
If you deployed Dashboard Server via the Azure Marketplace:
The default location for the SquaredUp folder is
F:\
.SquaredUpv[Version Number]
For example, for Dashboard Server Azure Edition v5 the default location isF:\SquaredUpv5
and for v4F:\SquaredUpv4
.If you installed Dashboard Server using the installer:
The default location for the SquaredUp folder is
C:\inetpub\wwwroot\SquaredUpv[Version Number]
, but a custom location may have been chosen during the installation.
For example, for Dashboard Server v5 the default folder location isC:\inetpub\wwwroot\SquaredUpv5
and for v4C:\inetpub\wwwroot\SquaredUpv4
Delete the
squaredup.index
file in..\SquaredUpv5\Transient\Cache\ExtensionPacks
Start the Dashboard Server Application Pool.
Remember to change
"trace-all-queries": true
to"trace-all-queries": false
in theextensionpacks.json
file and recycle the Dashboard Server application pool.Check that you can now log in.
Comments
0 comments
Please sign in to leave a comment.